Back to overview
Degraded
Degraded performance & delays for Europeans
May 12, 2026 at 2:50pm UTC
Affected services
vertexia.xyz
Resolved
May 12, 2026 at 3:02pm UTC
Servers are going back to normal operation, sorry for the issue!
Affected services
Created
May 12, 2026 at 2:50pm UTC
We're investigating the issue
Affected services